logo
Welcome Guest! To enable all features please Login. New Registrations are disabled.

Notification

Icon
Error

Options
Go to last post Go to first unread
viper89  
#1 Posted : Wednesday, May 18, 2011 7:24:58 PM(UTC)
viper89

Rank: Newbie

Groups: Registered
Joined: 5/18/2011(UTC)
Posts: 3

Thanks: 2 times
1st this is an awesome piece of software.

As I run missions I wanted to write down some things that caught my eye

Bugs
Athran Exigency 1 of 5 - Lvl 1 caldari - The mission calls for you to move to 5km of a mining outpost, yet the software doesnt do that.

Feature Request
Looks great so far!
Sponsor

Wanna join the discussion?! Login to your forum account. New Registrations are disabled.

Battowsai  
#2 Posted : Wednesday, May 18, 2011 8:21:34 PM(UTC)
Battowsai

Rank: Member

Groups: Registered
Joined: 4/20/2011(UTC)
Posts: 18

Was thanked: 1 time(s) in 1 post(s)
well... than u might need to tell the programm to do so ^^

Quote:
<action name="MoveTo">
<parameter name="Target" value="Abandoned Mining Station" />
</action>


Ad this to the Mission xml for that mission.

If you dont have a mission xml create one.


that should be:
"Athran Exigency (1 of 5).xml"
Quote:

<?xml version="1.0" encoding="utf-8" ?>
<mission>
<pockets>
<pocket id="0">
<damagetype>Thermal</damagetype>
<actions>
<action name="MoveTo">
<parameter name="Target" value="Abandoned Mining Station" />
</action>
<action name="ClearPocket" />
<action name="Done" />
</actions>
</pocket>
</pockets>
</mission>


Hope that helped you.
thanks 1 user thanked Battowsai for this useful post.
viper89 on 5/18/2011(UTC)
viper89  
#3 Posted : Wednesday, May 18, 2011 9:18:07 PM(UTC)
viper89

Rank: Newbie

Groups: Registered
Joined: 5/18/2011(UTC)
Posts: 3

Thanks: 2 times
Do i need to write the code for every mission? i see some people posted code for other missions so i am assuming i can just use their's?
Battowsai  
#4 Posted : Wednesday, May 18, 2011 10:10:36 PM(UTC)
Battowsai

Rank: Member

Groups: Registered
Joined: 4/20/2011(UTC)
Posts: 18

Was thanked: 1 time(s) in 1 post(s)
Here
there are manyxml files.

But if you do not find the mission you need there u need to make ur own xml.
PoorNewb23  
#5 Posted : Wednesday, May 18, 2011 10:39:44 PM(UTC)
PoorNewb23

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2011(UTC)
Posts: 88

Thanks: 2 times
Was thanked: 5 time(s) in 4 post(s)
If Questor won't find mission.xml for given mission, it will attempt to complete mission with looping set of default actions:
1. clear pocket.
2. Activate gate.

If mission in question is simple enough (kill all npcs in all pockets), it might be enough to complete it.

WARNING!!!: If mission cannot be completed, Questor will attempt to do mission ad infinitum and that is very likely to be spotted by CCP CCP's behavioral tracking, thus getting you banned.

You should never really depend on default actions doing the missions for you and instead simply keep bot under watch until you are sure that you have failureproof xml's for 100% missions.


Code for missions for and against (important! enemy factions vary on agent location, sometimes you can get same mission against two different factions from same agent) should work. There is always room for optimalizations (commands like ignore and breakonattackers were implmentedafter most of missions pack were written, and using them can help you a lot with tank requirements).


What Questor cannot do:
1. Switch ships. (that stupid shuttle mission)
2. Drop items into containers.
All missions that require those should be put into ignore list. Hopefully, it's mostly issue with lv1-3 missions, lv4 kill missions are mostly standard fare (the Anomaly [such a fitting name] being only exception, I think)
thanks 1 user thanked PoorNewb23 for this useful post.
viper89 on 5/19/2011(UTC)
viper89  
#6 Posted : Thursday, May 19, 2011 12:33:34 AM(UTC)
viper89

Rank: Newbie

Groups: Registered
Joined: 5/18/2011(UTC)
Posts: 3

Thanks: 2 times
im noticing that questor gets stuck in between missions and will not continue without manual intervention ( clicking the start button )

at 1st serpent suggested that i reset the ingame windows, which seemed to fix the problem for a bit.

however that issue has returned
PoorNewb23  
#7 Posted : Thursday, May 19, 2011 12:34:53 AM(UTC)
PoorNewb23

Rank: Advanced Member

Groups: Registered
Joined: 2/18/2011(UTC)
Posts: 88

Thanks: 2 times
Was thanked: 5 time(s) in 4 post(s)
Clear EVE cache, make sure you don't close Journal and Items windows. Those are two most frequent causes.

Edited by user Thursday, May 19, 2011 12:35:43 AM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.