logo
Welcome Guest! To enable all features please Login. New Registrations are disabled.

Notification

Icon
Error

Options
Go to last post Go to first unread
yoshii  
#1 Posted : Sunday, March 27, 2011 7:40:13 AM(UTC)
yoshii

Rank: Member

Groups: Registered
Joined: 3/22/2011(UTC)
Posts: 13

Thanks: 2 times
Using March 9th release.

After completing a mission that is a few jumps away from my agent's home station, Questor attempts to travel back to said station using the Traveler module. However, the distance between these particular stargates is large enough to drain my capacitor to under 25% (panic level).

Puts bot into an infinite warping-loop as it takes refuge in a station, warps back to mission, finds mission complete, then tries to warp back to home station, cap goes to panic level, repeat.
Sponsor

Wanna join the discussion?! Login to your forum account. New Registrations are disabled.

Gray  
#2 Posted : Sunday, March 27, 2011 12:39:06 PM(UTC)
Gray

Rank: Advanced Member

Groups: Gray, Registered
Joined: 2/13/2011(UTC)
Posts: 637

Thanks: 42 times
Was thanked: 35 time(s) in 23 post(s)
OhMyGod But this bug was already reported, and Da_Teach even said he fixed it, and moved it to archive? Not that I tested it myself, because I've fixed it my own way (made panic never fire if we're in "gotobase" state).
yoshii  
#3 Posted : Sunday, March 27, 2011 5:59:55 PM(UTC)
yoshii

Rank: Member

Groups: Registered
Joined: 3/22/2011(UTC)
Posts: 13

Thanks: 2 times
well.. it's definitely back. I came back to find my ship warping between a station and stargate for at least two hours..

Edited by user Sunday, March 27, 2011 6:00:30 PM(UTC)  | Reason: Not specified

vercetti  
#4 Posted : Sunday, March 27, 2011 6:31:49 PM(UTC)
vercetti

Rank: Advanced Member

Groups: Registered
Joined: 1/26/2011(UTC)
Posts: 89

Thanks: 4 times
Was thanked: 4 time(s) in 4 post(s)
Been answered, in char.xml set minimum cap before bot warps to safety to -1, problem solved.

Edited by user Sunday, March 27, 2011 6:32:38 PM(UTC)  | Reason: Not specified

Gray  
#5 Posted : Sunday, March 27, 2011 7:00:00 PM(UTC)
Gray

Rank: Advanced Member

Groups: Gray, Registered
Joined: 2/13/2011(UTC)
Posts: 637

Thanks: 42 times
Was thanked: 35 time(s) in 23 post(s)
Originally Posted by: vercetti Go to Quoted Post
Been answered, in char.xml set minimum cap before bot warps to safety to -1, problem solved.

I hope it was answered by some newbie rather than Da_Teach... You can't set minimumCapacitorPct to 0 or even -1, even at passivetanked ships, because your next NOS enemy would be your death with high probability. As soon as your cap goes to 0 at a battlecruiser (shieldtanked and speedtanking, I assume), your AB and invuls go off. Then you lose your shield in like 2-3 secs, and your ship pops before it's aligned to warp.

Roundabout ways do not work, it needs real fix. Use mine at your own risk: find "// If Panic is in panic state, questor is in panic state :)" comment in Questor.cs and add after that:

if (State == QuestorState.ExecuteMission)

(before "State = QuestorState.Panic;").
vercetti  
#6 Posted : Sunday, March 27, 2011 7:25:30 PM(UTC)
vercetti

Rank: Advanced Member

Groups: Registered
Joined: 1/26/2011(UTC)
Posts: 89

Thanks: 4 times
Was thanked: 4 time(s) in 4 post(s)
Fair point Gray.

Edited by user Sunday, March 27, 2011 7:28:11 PM(UTC)  | Reason: Not specified

iMutant  
#7 Posted : Wednesday, May 4, 2011 6:55:09 PM(UTC)
iMutant

Rank: Member

Groups: Registered
Joined: 4/18/2011(UTC)
Posts: 24

Thanks: 6 times
Have the same problem. or not the same... on missions without station, on low cap panic it warps out, and stay there forever.
rixim  
#8 Posted : Thursday, May 19, 2011 9:33:29 PM(UTC)
rixim

Rank: Advanced Member

Groups: Developer, Registered
Joined: 3/1/2011(UTC)
Posts: 88

Thanks: 31 times
Was thanked: 1 time(s) in 1 post(s)
This seems more like a ship build issue than anything else, if you can't make a strong argument otherwise, I will be ignoring this bug and suggesting this tread closed.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.